آسیب پذیری بحرانی XSS در وردپرس

میلیون ها سایت وردپرس در معرض خطر حملات اسکریپت بین سایتی قرار دارند. این حملات ناشی از وجود یک آسیب پذیری است که به طور پیش فرض در نصب محتوی سیستم مدیریت قرار دارد.

David Dede، محقق امنیتی روز پنج شنبه هشدار داد که این آسیب پذیری یک نقص اسکرییت بین سایتی است که در پلاگین و تم هایی که به طور پیش فرض در سایت های وردپرس جدید نصب می شوند وجود دارد. این محقق گفت: تخمین تعداد سایت های آسیب پذیر دشوار است اما میلیون ها سایتی که از پلاگین ها و تم های آسیب پذیر استفاده کنند در معرض خطر قرار دارند و بنا به گزارشات در حال حاضر از این آسیب پذیری در حملات سایبری سوء استفاده می شود.

علاوه بر این پلاگین JetPack، نیز نسبت به آسیب پذیری XSS مبتنی بر DOM آسیب پذیر می باشد. این پلاگین، که ابزار سفارشی سازی، تجزیه و تحلیل ترافیک و widgetهای جدید را پیشنهاد می دهد به طور فعال بر روی بیش از میلیون های وب سایت در حال استفاده است.

در صورت سوء استفاده موفقیت آمیز از این آسیب پذیری، نقص XSS می تواند برای اجرای کد جاوا اسکریپت در مرورگر و ارتباط ربایی وب سایت وردپرس مورد سوء استفاده قرار بگیرد. در صورتی حمله با موفقیت انجام می شود که صاحب سایت به عنوان ادمین وارد سایت شده باشد.

Dede اظهار داشت سوء استفاده از این آسیب پذیری بسیار ساده است. هم چنین اصلاح این آسیب پذیری ساده است و به راحتی می توان با حذف فایلgenericons/example.html این مشکل را برطرف کرد. به صاحبان سایت های وردپرس توصیه می شود تا سریعا این کار را انجام دهند.


Tuesday, April 5, 2016

« برگشت

Powered by WHMCompleteSolution